Tuesday, August 8, 2017

WSUS 3.0 SP2 Re-installation Failure due to .NET Framework and Update Services Folder

I’ve just resolved this issue half an hour ago. Customer uninstalled WSUS 3.0 SP2 but failed to reinstall it back later.

The WSUSSetup.log under %temp% showed Error 0x80070643

2017-08-07 11:14:36  Error     MWUSSetup          InstallWsus: MWUS Installation Failed (Error 0x80070643: Fatal error during installation.)
2017-08-07 11:14:36  Error     MWUSSetup          CInstallDriver::PerformSetup: WSUS installation failed (Error 0x80070643: Fatal error during installation.)
2017-08-07 11:14:36  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup failed (Error 0x80070643: Fatal error during installation.)
2017-08-07 11:14:40  Error     MWUSSetup          DoInstall: Wsus setup failed (Error 0x80070643: Fatal error during installation.)

From the event viewer, Event ID 11722 showed that the installation is failed with Error 1722.

image

I came across Anoop Blog and resolve the installation issue. In short, WSUS 3.0 SP2 doesn’t like .NET Framework 4.6 or later very much, WSUS cannot detect those newer version. Here are some official article/blog from Microsoft regarding that, https://support.microsoft.com/en-us/help/3045727/cannot-install-wsus-3-2-on-a-server-with-the-net-framework-4-6-or-late and https://blogs.technet.microsoft.com/wsus/2017/06/12/microsoft-net-framework-4-7-coming-to-wsus/ 

The resolution is to uninstall .NET Framework 4.6 or later before the WSUS 3.0 SP2 installation. You can install the .NET Framework after the WSUS 3.0 SP2 completed.

The WSUS finally installed!
BUT more errors pops out from the event viewer.
Event ID 7053, 12022, 12032, 12012, 12002

image

image

I have tried a lot of things that people suggested like delete the wsus MMC profile under %appdata%\Microsoft\MMC, change the WsusPool Identity and Manage Pipeline, remove then re-add the Windows Process Activation Services from Server Manager, verify the permission on all the required folder, and SQL permission.

None of the above resolve my issue until I perform the steps below:

  1. Uninstall WSUS 3.0 SP2 from program and features
  2. Verify SQL SUSDB has been deleted, D:\WSUS content has been deleted.
  3. Manually delete C:\Program Files\Update Services folder. This is the step that resolve the issue. There will be some leftover files after the WSUS uninstalled, which will not be replaced even after the WSUS re-installation
  4. Delete the MMC profile under %appdata%\Microsoft\MMC
  5. Reboot the server
  6. Run the WSUS 3.0 SP2 setup.
  7. You should be able to see the WSUS Wizard prompt. This mean that the installation is successful!
  8. Close the Wizard, do not configure, let SUP do the configuration later.
  9. Install the WSUS latest patch. I installed KB2938066
  10. Install the SCCM SUP role

For your reference:
WSUS 3.0 (SP2):     Build 3.2.7600.226
WSUS 3.0 (SP2) + KB2720211:     Build 3.2.7600.251
WSUS 3.0 (SP2) + KB2734608:     Build 3.2.7600.256
WSUS 3.0 (SP2) + KB2828185:     Build 3.2.7600.262
WSUS 3.0 (SP2) + KB2938066:     Build 3.2.7600.274

1 comment:

  1. wow!just amazing,very useful information about microsoft intune,EMS and SCCM.it is related to my field,i have learned a lot from your blog,thank you for sharing with us.

    ReplyDelete